Provider outage affecting Post Office Deposits
Incident Report for Countingup
Resolved
We are closely monitoring this incident, but we are pleased to report that full service has been restored.
Posted Jan 22, 2024 - 21:25 GMT
Investigating
One of our providers is experiencing technical difficulties, which is affecting the processing of Cash Deposits via the Post Office.

You will still be able to deposit into your account via PayPoint locations or account transfers.

We are working with our provider to resolve this as soon as possible and apologise for any inconvenience caused.
Posted Jan 22, 2024 - 17:56 GMT
This incident affected: 💰 Cash deposits.